New members must contact admin@mg42.us to have their account activated. Please include your username.

salt

TNW MG34 cycle issues

Anything MG34 related.
CavTrooper
Oberstabsgefreiter
Oberstabsgefreiter
Posts: 30
Joined: Mon Jul 27, 2009 10:51 pm
Anti-spam: Mg42

TNW MG34 cycle issues

Postby CavTrooper » Fri Aug 12, 2016 4:03 pm

I assembled a TNW receiver/semi auto bolt parts on a MG34 kit. Modified and the bolt with TNW parts, lapped the ways in. Receiver cams installed, rivets polish smooth and receiver edges blended into the cams. Using original style new trigger spring to lighten cocking. Lots of stoning and polishing. I can feed dummy rounds and they feed and eject but, I found that a couple jammed in the feed way and pushed the round into the case. I thought it was just a fluke. Took the gun to the range today and using Romanian ammo, it will fire a chambered round but will not eject most of the time, if it does eject, the next round will jam and push the bullet into the case. I assume part may be short cycling. Booster is 9.17MM, cone is tightened and locked into first notch that aligns at slight back off from full lock. I'm using a uhmw block to hold bolt open to load belts, pull the cocking lever back and the block drops out and the round chambers and fires first time. All problems happen after first cycle. Nice barrel, clean chamber. Ejector extends to front of bolt face when it engages ejector plate and plate is secured tight. Original ejector rod. Sometimes the empty cartridge does not eject and rams back into edge of chamber and mashes case mouth. All is well lubed and using TNW specified grease. Do I need to adjust recoil spring? Recuperator is functioning and barrel returns without binding. Any ideas??

Thanks

  • Similar Topics
    Replies
    Views
    Last post

Return to “MG34 General Discussion”



Who is online

Users browsing this forum: Bing [Bot] and 1 guest